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Introduction to Comodo Offline Updater 
Utility

The Comodo Offline Updater Utility allows administrators to configure a local server to download, store and provision database 
and program updates to networked computers running software such as Comodo Internet Security. The utility can be installed 
on a local server and configured to periodically download CIS signature and program updates from http://download.comodo.com 
(default). Once downloaded, this local server can then act as the CIS update server for some or all of the managed machines on 
the network. Setting up a local update server often allows an organization to save time and bandwidth when rolling out updates 
to a large number of managed nodes.

 This utility is designed to provision updates to installations of Comodo Internet Security (CIS) that are running under the control 
of Comodo EndPoint Security Manager (CESM). Future releases may include full integration with the standalone (or 'home 
user') versions of CIS.

• Administrators can install the update utility on any server but should note that  this machine must be available at all 
times to the managed computers it is set to provision  (it may be most convenient to install the utility on the same 
machine as the CESM Service). The update utility can be freely installed on 'managed' and 'non-managed' machines 
alike. Installing on a 'non managed' machine does not count towards your number of CESM licenses.

• Comodo Internet Security is the only CESM controlled product that can be serviced by this updater. Future versions 
will include support for Comodo Disk Encryption.

• The utility has its own graphical user interface which must be configured on the local machine. It is not possible to 
configure  the update utility from the CESM console. The default installation path is drive:\Program 
Files\Comodo\Offline Updater . Double click 'OfflineUpdater.UI.exe' to begin configuration. 

• CESM Administrators - It is possible to install the utility remotely onto managed machines by creating a Task that 
contains the 'Install Package' action. The package is named 'OfflineUpdater.Setup.<version_number>.msi. This may 
be useful for pushing the application out to multiple servers when, for example, load balancing is required.

• CESM Administrators must change the 'CIS Update Host List' on each required CIS installation to point to the URL of 
the local update server. Doing so will mean that the individual installations of CIS will check for and download updates 
from the local server instead of from http://download.comodo.com. The individual installations of CIS can be instructed 
to use the local server by using the 'CIS - Set Update Host List' Action. This Action, like all other CESM Actions, can be 
implemented on all required machines at the same time by selecting them as Targets during the creation of the Task. If 
you would like to see a more complete explanation of 'Actions', 'Sequences' and 'Tasks' then please refer to the 
dedicated CESM Admin guide available from http://enterprise.comodo.com/. 

For guidance explaining the installation of the updater utility on your server, please refer to 'Installing Comodo Offline Updater 
Utility'. 

For guidance to configure the utility, see 'Configuring and Using Comodo Offline Updater Utility'.

Installing Comodo Offline Updater Utility
Comodo Offline Updater Utility can be installed on any local server and will provision endpoint machines with database and 
software updates. After installing the utility the application downloads the updates for Comodo Internet Security from 
http://download.comodo.com and stores them locally in the server. The CIS installations in the remotely managed computers 
can be configured so that they can download these updates from this local network server. This section explains the installation 
of the utility on the server. For detailed explanations on the configuration of the application, see  'Configuring and Using 
Comodo Offline Updater Utility'.

Comodo Offline Updater Utility User Guide | © 2013 Comodo Security Solutions Inc. | All rights reserved                3

http://help.comodo.com/admin/cesm_local_update_server.html
http://enterprise.comodo.com/


Comodo Offline Updater Utility - User Guide

1. Downloading and running the installer

To set up the Comodo Offline Updater on the CESM Server, download and save the 
'OfflineUpdater.Setup.<version_number>.msi' installation file. To start installation of the application, double click the 
installation file icon. The welcome screen will be displayed.

Click 'Next'. 

2. License Agreement

The End User License Agreement will be displayed.
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To complete the installation phase you must read and accept the License Agreement. After you have read the End-
User License Agreement, check the 'I accept the terms in the License Agreement' box and click 'Next' to continue 
installation. If you decline, you cannot continue with the installation. 

3. Choosing Destination Folder

The next step is to choose the destination folder in your server for the installation of the Comodo Offline Updater.

To install the application in the default location, click 'Next'. If you want the application to be installed in a different 
location, click 'Change' , navigate to the desired folder and click 'Next'.

4. Ready to Install

After completing the configuration options to your satisfaction in the preceding steps, a confirmation dialog will be 
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displayed.

Click the 'Back' button to review and/or modify any of settings you have previously specified. To confirm your choices 
and begin the installation of the Comodo Offline Updater, click 'Install'.

A setup status dialog box is displayed. You will see a progress bar indicating that files are being installed.

5. Installation Complete

The Installation Complete dialog is displayed indicating the successful completion of installation.
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Click 'Finish'. Comodo Offline Updater is successfully installed in your server.

Note: CESM administrators can install Comodo Offline Updater on several servers within the network if the Administrator 
wants to setup multiple local update servers. This can be done through the CESM console by creating a task to install the 
application .  For more details, see the CESM Admin guide sections  'The Package Management Window', 'The Sequence 
Manager Window ' and 'The Task Manager Window'.

 

Configuring and Using Comodo Offline 
Updater Utility

Once installed, the Offline Updater utility can be started from the Windows 'Start' menu.

Click Start > All Programs > Comodo > Offline Updater  > Comodo Offline Updater.

This section of the guide covers basic usage and configuration of the application. Please use the links below to go straight to the 
section you need help with:

• Comodo Offline Updater Utility - Interface Basics;

• Persistent Navigational Elements -The File Menu And Shortcut Toolbar;

• Overview Of Download Log And Request Log Windows;

• Configuration Of Comodo Offline Updater Utility;

• CESM - Pointing Managed Installations Of CIS To The Local Update Server.
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Comodo Offline Updater Utility - Interface Basics 

The updater interface allows the administrator to:

• View download logs of database and software updates;

• View request logs from  managed computers;

• Configure the working folder and start or stop the service;

• Configure port, proxy and update refresh rate settings;

• Specify synchronization settings such as the download URL and folder path that the local server will contact to collect 
CIS updates from The Comodo Offline Updater main interface:

Persistent Navigational Elements -The File Menu and Shortcut Toolbar 
The File and Shortcut Toolbar provide access to all functional areas of the updater functionality. The File Menu can be accessed 
at all times and consists of four areas: File, Edit, View and Help. The Shortcut Toolbar, positioned directly below, provides fast 
and easy access to many of the functions contained in the 'File', 'View' and 'Edit' areas of the the file menu. 

The following table contains a brief summary of these areas: 
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File Menu 
Element 

 
Equivalent Shortcut Toolbar Icon Description

 File  Contains program commands relating to start 
or stop the Comodo Offline Updater service and 
shutdown. 

 Start Starts the offline updates service. 
Note: This button is disabled if the service is 
already running. 

 Stop  Stops the offline updates service. 
Note: This button is disabled if the service is 
already stopped and not running. 

 Restart  Restarts the currently running offline updates 
service.

Updates 
Information None

Opens the 'Updates information' dialog that 
displays a log of update events of CIS Antivirus 
bases and a log of update events of CIS binaries.

 Exit  None Closes down the application.

 Edit
 

 Contains shortcuts to select and copy log 
entries, search for entries in the log and 
specifying configuration settings for the 
Comodo Offline Updater utility.

Copy

None

Copies the selected text contents from the log 
window to the clipboard. 

The log entries can also be copied to the clipboard 
by right clicking on the selected entry or entries and 
selecting 'Copy' from the context sensitive menu. 

 Select All None Selects all the text contents in the log window for 
copying to the clipboard.

 Find  Opens the 'Find' dialog for searching through the 
log entries with specific search keywords. 

 
Language

None  Allows the administrator to change the language of 
the Comodo Offline Updater utility. Currently 
available languages are English and Chinese 
(Simplified). Language changes will be applied only 
after restarting the utility.

Settings Opens the 'Configurations Settings' dialog for 
specifying the configuration settings for the 
Comodo Offline Updater utility. See 'Configuration 

Comodo Offline Updater Utility User Guide | © 2013 Comodo Security Solutions Inc. | All rights reserved                9



Comodo Offline Updater Utility - User Guide

 
File Menu 
Element 

 
Equivalent Shortcut Toolbar Icon Description

Of Comodo Offline Updater' for more details.

 Logs  Contains shortcuts that open up the Download and 
Request Log windows.

 Download 
Logs

None Opens the Download Log Window. The Download 
Log window can also be opened by clicking the 
'Download Log' tab above the Log window.

Request 
Logs

None Opens the Request Log Window. The Request Log 
window can also be opened by clicking the 
'Request Log' tab above the Log window.

Clear  Clears the current logs.

 Refresh Updates the entire list of entries in the displayed 
log window so that the list incorporates the latest 
entries.

 Help  
Contains shortcut that opens the 'About' dialog. 

 About  None Opens the About dialog that displays the version 
number and copyright information of. 

Overview of Download Log and Request Log Windows 

'Download Log' Window

The Download Log window displays a list of status messages concerning the initiation, progress and success or failure of all 
download activities ( both binary and database downloads) alongside the time the message was generated. It can be viewed by 
clicking the 'Download Logs'  tab or clicking  View > Download Logs.
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'Request Log' Window

The Request Log window displays a list of download requests made by managed installations to the local update server. 
Information displayed includes the IP and Port number of the originating request, the location of the file that was requested; the 
time of the request and the agent that made the request (the 'agent' is usually the endpoint product such as Comodo Internet 
Security). The 'Request Log' window can be viewed by clicking the 'Request Logs' tab or clicking 'View > Request Logs'.
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The Download Log window displays a list of status messages concerning the initiation, progress and success or failure of all 
download activities ( both binary and database downloads) alongside the time the message was generated. It can be viewed by 
clicking the 'Download Logs'  tab or clicking  View > Download Logs. The Request Log window displays a list of download 
requests made by managed installations to the local update server. Information displayed includes the IP and Port number of the 
originating request, the location of the file that was requested; the time of the request and the agent that made the request (the 
'agent' is usually the endpoint product such as Comodo Internet Security). The 'Request Log' window can be viewed by clicking 
the 'Request Logs' tab or clicking 'View > Request Logs'. 

Download Logs and Request Logs Windows – Table of Columns, Controls and Icons

Item Name Type Description

  (Message) 
Icon Log entries that are classified as 'Messages' typically 

inform the administrator of the successful completion 
of the events. For example - a notification that a 
download has been successfully completed or that a 
request has been received. 

(Warning) 
Icon Log entries that are classified as 'Warnings' alert the 

administrator to potential network issues that may 
impair the activity, for example a download event or 
provisioning the update files for a received request 
from a managed computer. 
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Download Logs and Request Logs Windows – Table of Columns, Controls and Icons

(Error) 
Icon Log entries that are classified as 'Errors' inform the 

administrator of the failure of the event 

Description Column header A text description of the specific log entry. For 
example - a notification that a download has been 
successfully completed or that a request has been 
received. 

Time Column header Shows the time and date that the event was 
executed. For example the date and time at which the 
updates were downloaded or the date and time at 
which a request was received from a managed 
computer. 

Source Column header The IP address and port number of the managed 
computer from which the request originated. 

User Agent Column header Displays the name of the service responsible for 
generating the request. In almost all cases this will be 
the installed product on the end point machine (for 
example, Comodo Internet Security). 

Filter Clicking the 'Errors' button enables the administrator 
to view only the log entries that are classified as 
errors. 

Filter Clicking the 'Warnings' button enables the 
administrator to to view only the log entries that are 
classified as Warnings. 

Filter Clicking the 'Messages' button enables the 
administrator to to view only the log entries that are 
classified as Messages. 

Configuration of Comodo Offline Updater Utility 
The updater can be configured for the working folder in the server to store the downloaded AV database updates, download 
URL, and the proxy settings. The configuration settings interface can be accessed by clicking the 'Settings' button or Edit > 
Settings from the main interface.
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Synchronization Settings

• Remote Folders. The ‘Remote Folders’ section displays the location of the update files on the ‘Download 
Server’. This is the path that the offline updater will attempt to connect to in order to download updates. This is 
specific to the domain stated in the ‘Download server’ field of this same interface. The default location is to 
download updates from http://download.comodo.com/<path>. There are two basic ways that remote folders can 
be configured – automatically or manually. There are also two ‘types’ of download, namely ‘Bases’ and ‘Binaries’ 
– each of which will usually have distinct remote folder paths. 

Note: In most cases, there shouldn’t be any reason for administrators to change the synchronization settings. Possible 
exceptions could include if the administrator needed to download files for uncommon/older versions of an endpoint product and 
knew the location of those files on the remote server; if Comodo communicated to the administrator that their download server 
and/or path has changed or if the administrator wants to download the updates to this server from another server in the local 
network.

• Remote Folders =  Folders on the 'Download' server (download.comodo.com by default), that Offline 
Updater checks for AV bases and binary updates.

• Bases = Database updates (like antivirus signatures updates). This type of update is the most frequent.
• Binaries = Endpoint Product Updates (software updates and upgrades). This type of file will typically be 

downloaded less frequently than the (data) bases.

• Automatically detect remote folders from client requests – Automatically sets then synchronizes with the 
folder path on the server that has been specified in the requests from the clients. This is the default and 
highly recommended setting.

• To manually set the folder structure in the server, deselect the checkbox beside 'Automatically detect 
remote folders from client requests'' and add the path of the remote folder in the 'Remote Folder' column and 
the type of the data in the 'Type' column (see this note before changing this setting).
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• Working Folder  - The working folder  text box allows the Administrator to specify the path of the local storage 
location for storing the downloaded database updates and binaries. To change the destination folder, click 
'Browse' and navigate to the desired location to store the updates.

• Download Server - The Download Server  text box allows the Administrator to specify the URL from which the 
updates are to be downloaded. The default the download URL is http://download.comodo.com. This can be 
changed if the updates are available from any other server in the local network.

• Ports to Listen -  Port 80 is the default port number that the Comodo Offline Updater utility will listen to for the 
database updates.

• Refresh Every (Secs) -This setting allows the Administrator to set the frequency the download server has to be 
checked for the latest updates. 

Proxy Settings

The proxy settings allows the Administrator to configure how Comodo Offline Updater utility should connect to Comodo servers 
for receiving database updates.  If a Proxy server is used in the network  and if the Administrator wants the application to use the 
Proxy Server, the Proxy settings can be configured  accordingly.

To use a proxy server to receive the updates

1. Select the check box beside 'Use Proxy'.

2 .Enter the proxy server IP address or name in the 'Server' text box.

3 Enter the port number in the 'Port' text box.

4.Type your Log in ID and the Password for proxy server authentication.

• Click OK for your settings to take effect. 

CESM - Pointing Managed Installations of CIS to the Local 
Update Server 

After the installation and configuration of the updater utility, CESM administrators can create a Task that will instruct managed 
computers to collect their updates from the local server. The local server is, therefore, the machine that contacts the Comodo 
servers to download updates which it then provisions to the endpoint machines. This is done by creating a Sequence containing 
the action 'CIS - Set Update Hosts List' (see the dedicated CESM user guide for more details on Actions, Sequences and Tasks 
- available from http://enterprise.comodo.com/). The host address of the local CESM server should be specified as the Update 
URL parameter for the 'CIS - Set Update Hosts List'  action while configuring the sequence.

Step 1 - Creating a New Sequence Containing the Action CIS - Set Update URL
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1. Open the Sequence Manager Window by clicking 'View' > 'Sequence Manager' from the file menu or clicking the 

button from the toolbar.

2. Click the 'Add' button       to create a New Sequence.

3. The 'Add New Sequence' dialog will be opened. At this stage, you should create an appropriate Name (for example, 
'Set Update URL for CIS Installations') and (optional) Description for the Sequence  (for example, 'Setting CIS 
Installations for offline update').

4. Click the 'Add Action' icon                              and select the Action 'CIS - Set Update Hosts List'. 

5. Specify the parameters of this Action from the panel to the right.  Click the ellipses button (...) from the 'Host List' 
row. 

The 'Hosts List Editor' dialog will appear. Click 'Add' and type the URL in the 'URL' field. This can be entered as the 
host name or IP address of the local update server. For example, if you have installed and configured the Comodo 
Offline Updater Utility in the CESM Server, type the host name or the IP address of the CESM Server. Click 'OK'.
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6. Click 'Save'. This Sequence of Actions can now be added to a Task to be deployed on the target machines. 
Alternatively, click the drop-down arrow beside 'Save' and select 'Save and Create Task' to create a task containing 
this sequence immediately. The precess moves to Step 5 of the next stage 'Creating a New Task containing the 
Sequence with the action CIS - Set Update Hosts List'.

Step 2 - Creating a New Task Containing the Sequence with the action CIS - Set Update Hosts List

1. Open the Task Manager Window by clicking 'View' > 'Task Manager' from the file menu or clicking the  button from 
the toolbar.

2. Click the 'Add' button            to create a New Task.

3. The 'Add New Task' dialog will be opened. At this stage, you should create an appropriate Name (with references to 
the sequence of actions and the target computers. For example,  'Set Update URL for CIS on Vista Computers' or 'Set 
Update URL for CIS on Accounts Dept Computers') and (optional) Description for the Task you are about to create.

4. Add the newly created Sequence to the Task, by clicking the drop-down button at the end of the 'Sequence' field 
and selecting the newly created sequence from the drop-down list.

5. Select the desired target computers or a predefined CESM 'Group' of computers for which the Update URL has to 
be set, in the 'Targets' field editor.

6. Execute the Task:

• Immediately by selecting 'Save and Execute';
• Manually at any time in the future by first saving then selecting the Task in the 'Task Manager' window then 

clicking the 'Execute' icon;
• At a scheduled time by configuring your preferences using the 'Schedule' tab. 

Once the Task is executed, the Administrator can check the progress (Success or Failure) of the Task  through the 'Task Result 
Manager' Window, which can be accessed by clicking History > Task Result or Task Result Manager button     

 from the toolbar.
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Tip: You can also select the computer(s) from the Computers window, right click on them and select 'Create Task' from the 
context sensitive menu. You can create a new task for setting  the update URL list for the selected computer(s) with a 
sequence containing the action 'CIS - Set Update Host List' and execute on the computer(s).

Additional Notes: The  Administrator can find the current Update URL for any computer by assigning a Task with a Sequence 
containing the Action 'Discovery Data'. The parameter for the Discovery Data should be specified as  'CIS - Update URL' .

To check the current update URL for any computer:

1. Create a new sequence by selecting the Action as 'Discover Data '

2. Specify the Discovery parameter as  'CIS - Update Hosts List' and click the drop-down arrow beside 'Save' and 
select  'Save and Create Task'.
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3. Specify the computer for which the current Update URL has to be found.

4. Execute the Task by clicking the drop-down button beside 'Save' and selecting 'Save and Execute'.

5. Once executed,  open 'Discovery Profiles' Window by clicking View > Discovery Profiles from the file menu or 

clicking the Discovery Profiles icon      from the toolbar.

6. Double click on the 'CIS - Update Hosts List' profile in the 'Discovery Profiles' Window or right click on the 'CIS - 
Update Hosts List' profile and select 'Open Discovered Data' from the context sensitive menu.

The list of computers on which the 'Discover Data' action with the Discovery Profile 'CIS - Update Hosts List' will be 
displayed.  Click the ellipses (...) button from the results panel on the right hand side of the list of computers, the 
Update URL list configured for the respective computer will be displayed in the 'Host List Editor' dialog.
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Alternatively, after executing the Task  with a Sequence containing the Action 'Discovery Data' with Discovery Profile 
'CIS - Update URL', right click on the desired computer in the Computer Tree in the Computers Window and select 
'Open Discovered data' from the context sensitive menu.

The discovery profiles for the selected computer will be displayed.
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Select CIS - Update Hosts List and click the ellipses (...) button from the results panel on the right hand side. The 
Update URL list configured for the respective computer will be displayed in the 'Host List Editor' dialog.

Shortcut Method for Creating a New Discovery Sequence

Alternatively, a new Discovery Sequence can be created from the context sensitive menu of  'CIS Update URL' Profile in the 
'Discovery Profiles' Window. 

1.  Open 'Discovery Profiles'  Window by clicking View > Discovery Profiles from the file menu or clicking the Discovery 
Profiles icon         from the toolbar. 

2. Right click on the 'CIS - Update URL' profile and select 'Create Discovery Sequence' from the context sensitive 
menu.

An 'Add New Sequence' dialog with a preset Sequence containing the the Action 'Discover Data' and Discovery Profile 
'CIS - Update Hosts List' will be opened.
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3. At this stage, you should create an appropriate Name and (optional) Description for the Sequence and save the 
Sequence.
The Administrator can create a new Task using this sequence and specifying the required computer(s) and execute 
the Task to check the current Update URL list configured for the selected computer(s). 

About Comodo
The Comodo companies are leading global providers of Security, Identity and Trust Assurance services on the Internet. Comodo 
CA offers a comprehensive array of PKI Digital  Certificates and Management Services, Identity and Content Authentication 
(Two-Factor - Multi-Factor) software, and Network Vulnerability Scanning and PCI compliance solutions. In addition, with over 
10,000,000 installations of its threat prevention products, Comodo Security Solutions maintains an extensive suite of endpoint 
security software and services for businesses and consumers. 

Continual innovation, a core competence in PKI and a commitment to reversing the growth of Internet-crime distinguish the 
Comodo companies as vital players in the Internet's ongoing development. Comodo, with offices in the US, UK, China, India, 
Romania and the Ukraine, secures and authenticates the online transactions and communications for over 200,000 business 
customers and millions of consumers, providing the intelligent security, authentication and assurance services necessary for 
trust in on-line transactions.

Comodo Security Solutions, Inc.

1255 Broad Street

Clifton, NJ 07013

United States

Tel: +1.888.256.2608 

Tel: +1.703.637.9361

Email: EnterpriseSolutions@Comodo.com

For additional information on Comodo - visit http://www.comodo.com.
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